Reference documentation for GraphQL schema types in the Other category.
A (potentially binary) string encoded using base64.
Represents non-fractional signed whole numeric values. Since the value may
exceed the size of a 32-bit integer, it's encoded as a string.
Represents true or false values.
A custom property value can be either a string or an array of strings. All
property types support only a single string value, except for the multi-select
type, which supports only a string array.
An ISO-8601 encoded date string.
An ISO-8601 encoded UTC date string.
Represents signed double-precision fractional values as specified by IEEE 754.
A Git object ID.
A fully qualified reference name (e.g. refs/heads/master).
Git SSH string.
An ISO-8601 encoded date string. Unlike the DateTime type, GitTimestamp is not converted in UTC.
A string containing HTML code.
ID of the object.
Type: ID!
Represents a unique identifier that is Base64 obfuscated. It is often used to refetch an object or as key for a cache. The ID type appears in a JSON response as a String; however, it is not intended to be human-readable. When expected as an input type, any string (such as "VXNlci0xMA==") or integer (such as 4) input value will be accepted as an ID.
Represents non-fractional signed whole numeric values. Int can represent values between -(2^31) and 2^31 - 1.
Information about pagination in a connection.
PageInfoendCursor (String): When paginating forwards, the cursor to continue.hasNextPage (Boolean!): When paginating forwards, are there more items?.hasPreviousPage (Boolean!): When paginating backwards, are there more items?.startCursor (String): When paginating backwards, the cursor to continue.An ISO-8601 encoded UTC date string with millisecond precision.
Workaround for re-exposing the root query object. (Refer to
https://github.com/facebook/relay/issues/112 for more information.).
Type: Query!
Represents textual data as UTF-8 character sequences. This type is most often used by GraphQL to represent free-form human-readable text.
An RFC 3986, RFC 3987, and RFC 6570 (level 4) compliant URI string.
A valid x509 certificate string.